ALAKALMI


A rendszer főmenüje:


Készült

Balatonszemes

2008 - 2020

Készítő: Kántás László

Telefon:(06-70) 501-8772

8636 Balatonszemes Bajcsy-Zs. u. 37.

Email.:lkantas@gmail.com


Feladata

  1. Feladata alkalmi munkavállalók törzsadatainak rögzítése, tárolása.

  2. Napi bejelentő kitöltése kiválasztottakról (csak rámutatás szüksége) a ??T1042E bizonylaton ÁNYK-ba, amit utána azonnal ügyfélkapun fel lehet adni. Bejelentés és törlés.

  3. Napi munkák lejegyzése ezekről kimutatások kifizetési jegyzékek, csoportosított listák. Elvégzett munkákat napi szinten kell lejegyezni (időszakot felbontva) és ezekből a rendszer összevont (egymás melletti napok) kimutatásokat készít.

  4. Hóvégén a kifizetés lejelentő ??08A/M kitöltése ÁNYK-ban amit csak fel lehet adni azonnal az ügyfélkapun. De ezek az ÁNYK dokumentumok tovább küldhetők. Tényleges kifizetések jelentése (kerekített, 5 Ft-ra kerekített)

  5. Ezek alapján rámutatással jelenléti ívek nyomtatása, a beállított paraméterekkel. Ezeket sorszámmal vagy anélkül lehet több példányban nyomtatni, amit a dolgozókkal helyszínen alá lehet íratni. Minden nyomtatást megjegyez a rendszer.

  6. Ezen kívül igazolás is nyomtatható szintén néhány kiválasztó kitöltésével. Üres jelenléti is nyomtatható.

  7. Minden bevitt adóazonosítót, és TAJ számot ellenőriz (NAV ellenőrző algoritmussal)! Ez segítség azoknak akik sok munkavállalót többször foglalkoztatnak, és gyorsan egyszerűen akarják az adminisztrációt elkészíteni. Néhány kiválasztó gombnyomással elérhetők a funkciók.

  8. Komplett kifizetési jegyzék időszakra kerekítve, 5 Ft-re kerekítve.

A rendszer megfelel a 2010. évi LXXV. törvényben foglaltaknak.

A megvett rendszerrel a regisztrált szolgáltató nyomtathat. A rendszerre egy év garancia vonatkozik, és örökös (nincs évi megújítási díj) használat.

A rendszer WINDOWS felületen fut. A rendszer MS VisualStudio 6.0-ban van írva, ami a dátumkezelést korrektül végzi. Futtatásához semmilyen licencre nincs szüksége csak egy telepítő csomagra, ami felteszi a futtató fájlokat. A telepítés teljesen automatikus.


Paraméterei

A gyűjtött adatok mennyiségét az ön merevlemezegységének, vagy központi hálózati gépének kapacitása határozza meg. Dátum formája normál magyar sorrendű /éééé.hh.nn/. Minden lista ékezetes a karakterkészlet lehetőségei szerint. Minden lista A4 lapra készült megkímélve önt az állandó nyomtatólap cserétől és lehetővé téve a gazdaságos papírfelhasználást. Bizonylatok tételsoronként kerülnek lejegyzésre, háttérben lejegyezve a feldolgozót, módosítót, törlést, végzőt is. A rendszerben fizikai törlés nincs beépítve csak törlésre bejelölés, ami lehetőséget ad a hibák javítására és elemzésére. Éves ciklust célszerű kezelni vele, év végi mentéssel és rendszer alaphelyzetbe állítással (gyűjtött adatok törlése). ÁNYK átadásokhoz szükséges a NAV nyomtatványkitöltő programjainak aktuális (az évre) letöltött verziója és telepítése ÁNYK-ba. ÉÉ08A/M és ÉÉT1042E nyomtatvány.

Nyomtatható:

  • Kitöltött jelenléti

  • Üres jelenléti

  • Igazolás

  • Napi elvégzett munkák listái

A rendszerre egy év garancia vonatkozik, és örökös (nincs évi megújítási díj) használat.


Optimum

XP - WIN10 futtató gép, vagy jobb, 1Gbyte Wincseszter, 256 Mbyte RAM, 17” színes monitor min.:800*600 felbontás, CD-ROM vagy USB port, 500W szünetmentes , minőségi egér, Windows operációs rendszer, laser vagy tintasugaras nyomtató. Internet kapcsolat az ÁNYK feladásokhoz. Feladni csak ügyfélkapun át lehetséges, amivel Önnek rendelkeznie kell!

Ezekért ön cserébe egy rendkívül kényelmes grafikus felületen kezelhető rendszer kap, ami minden Microsoft alkalmazásba könnyedén ad át adatokat /Word, Excel, stb./.


TELEPÍTÉS

Mivel a rendszer önmagát feltelepíti CD-ről nincs szükség semmilyen speciális ismeretre a telepítéshez. A rendszer árában ilyen nincs beépítve. Természetesen, ha Ön kéri a telepítést, ezt megrendelheti, de ilyen esetben kiszállási költséget fogok felszámolni, és Önnek kell biztosítani a beállított WINDOWS-al telepített gépet. A használathoz internet kapcsolat és ügyfélkapu regisztráció szükséges. Ha van telepi rendszere, akkor összekapcsolható annak adataival (csoport, szolgáltatás ). Ha nincs és ezeket is szeretné kezelni, akkor kérje ezek tellepítését. Csoport, költséghely nélkül is használható a rendszer ezen kimutatások nélkül, de a szolgáltatás kezelő szükséges ha nincs telepi rendszere.

BETANÍTÁS

A rendszer teljes dokumentációját megkapja, amit telepítés előtt a CD lévő feloszt.chm fájlra kettőt kattintva érhet el. Telepítés után a programot futtatva mindenhol az F1-el vagy a főmenü\egyéb\? érhető el. Itt minden olyan információ megtalálható, ami üzemeléshez szükséges. Ha Ön igényli természetesen, megrendelheti a rendszer bemutatását, betanítását, amiért felárat fogok számolni kiszállással. Ilyen esetben a WINDOWS rendszeren kívül, szükséges egy személy, akinek ez betanítható.

KISZÁLLÁS

A rendszer ára ilyet nem tartalmaz, függ a távolságtól, üzemanyag ártól amit egyeztetés után meg kell beszélnünk.

MÁS RENDSZEREKBŐL ADATOK

A vételár ilyet nem tartalmaz. Természetesen Ön megrendelheti, és szinte minden rendszerből át tudok Önnek adatokat emelni, de ezt megbeszélt felárért tudom elvállalni, és szükség lehet a másik rendszer írójával konzultálni, adatok elhelyezkedéséről információt kapni.


Regisztráció

Ön alap helyzetben egy bemutató (demó) változatot kap meg. Miután installálta a lemezére ( C:\alkalvb6 ) ezen kipróbálhatja a rendszer bizonyos megkötésekkel. Ha Ön úgy gondolja próba után, hogy Önnek ez megfelel, akkor a megjelölt összeg, és pontos neve elküldése után, én küldök egy számlát és egy jelszót amit a beállításoknál kell érvényesítenie. Ez után a rendszer megkötés nélkül szabadon használható.


Adatbázis

A Microsoft, sajnos elég gyakran cserél adatbázis kezelőket (adatbázis motort) ami szintén gátja lehet a rendszere működésének.

A rendszer Msaccess2000 adatbázist használ. Ha az Ön gépén más MSaccess van telepítve Office prof. csomaggal (Office, Office XP) akkor nem tud (csak konvertálás után) a rendszer ezekkel együtt működni. Egyszerű megoldás ha az Office telepítővel leveszi az újabb Msaccesst (ez olyankor célszerű, ha nem használja az új MSaccesst egyik alkalmazása sem). Ha ez nem lehetséges, mert olyan rendszere is van amelyik ezzel az újabbal dolgozik akkor szólnia kell, és én átkonvertálom az access2000 adatbázist az újra. Ha elakad, kérje segítségemet.


Menük és kezelésük

A Windowsban megszokott módon lehet minden rendszeremben a menüket kezelni. Legegyszerűbb az egérrel való kiválasztás, de lehetőség van, ha a rendszerbe installálva lett a billentyűzettel való kiválasztás. Ilyenkor a főmenü ( vízszintes menük ) pontok kiválasztásához nyomja meg a ALT billentyűt és ekkor a menü megmutatja mely pontoknál (betűknél) van aláhúzás kiválasztó betű előtt. Ezt lenyomva közvetlen a menüpontra ugrik a rendszer, és lenyílik a menü. A lenyílt menüben a kiválasztó betű lenyomására elindul a menüpont.

A menü felépítése, a lehetőségekhez mérten hasonlít a Microsoft programoknál megszokott elrendezéshez azért, hogy a felhasználónak ne keljen keresgetnie, pl. egy kilépés pontot.

Egyes menük csak akkor világosodnak ki, ha ezt logikailag lehetséges (pl.: nem lehet bevétel ha nincs raktár! stb.) vagy ha a regisztráció megengedi!


2013 újítások

Üres jelenléti lap nyomtatása adatkérő lap néven.

Igazolás nyomtatása.

Sorszám állítható, legyen-e.


2020-as újítások

Navnak ÁNYK bizonylatok kitöltése lejelentéshez.

Elvégzett munka bevitel, javítás, lista.

Törzsadat kezelésnél:

Költséghelyek

Csoport beállítás

Közteher


TÖRZSADAT


TÖRZSADAT

Foglalkoztatott

Feladata a foglalkoztatottak adatainak tárolása. Minden helyen az adóazonosítót, és TAJ számot ellenőrzi a rendszer. Át lett alakítva a NAV által kért adatokhoz.

Itt lehet a dolgozók, foglalkoztatottak adatait felvenni, javítani, törölni, listázni.


FOGLALKOZTATÓ TÖRZSADAT

A neve sort csak regisztrációkor lehet kitölteni és az fixen beégetésre kerül! Ez is átalakítva 2020-ban a NAV jelentésekhez szükséges adatokhoz.


Költséghely kezelés

Ez 2020-tól új.


Csoport beállítás

Ez akkor használható ha Önnek van telepi rendszere. Ott a csoport kezelő be van építve itt csak a beállításokat kell a csoporton elvégezni. A csoport és költséghely listák ez alapján készülnek.

Alul kiválasztva vagy vezetőt vagy Költséghelyet utána a sorra álva a javítandó oszlopon (Vezető vagy Költséghely) 2*kattintva lehet javítani.


Közteher

Ez be van állítva, csak ha NAV változtatja kell javítani.


Feldolgoz�s


NAVnak jelentés dolgozókról *T1042E

Pipa bejelölésével néhány kattintással kijelölhető kikről jelentsen a NAV-nak. A [Mehet..] gombbal indul a jelentés elkészítése ÁNYK-ba. Ez még nem megy sehova csak a *T104E dokumentumokat írja meg a rendszer, és átvált ÁNYK-ra. Itt javítható módosítható, ha szükséges a dokumentum, majd ha van intenetje és ügyfélkapu regisztrációja akkor átküldheti a NAV-nak. Itt lehet az átküldötteket törölni a törlendő kejelölésével törlés/visszavonás kijelölésével.


Elvégzett munka

Bevitel

Itt lehet a napi munkákat bevinni a rendszerbe. Csak egy napot lehet bevinni azaz ha 3 napos időszakot visz be azt háromszor kell felvinni minden dátumra. Bevitelt könnyíti alul a dátum + - léptethető és az [U.foglalk] nyomógomb ami az utolsó foglalkoztatott írja vissza. Ha alul kitöltötte a sort a [Tételek mentése] gombbal viheti be. Minden alsó sorban lévő adatot megjegyez a rendszer kivéve a foglalkoztatottat. Tábla kitöltése nem kötelező de ha nincs beállítva listában a csoport és költséghely listák is üresen jelennek meg. Jellege kiválasztásakor a közteher változik a törzsadatban beállítottra. Dátumra 2*kattintva kalendárium jelenik meg ahol kiválasztható az új dátum. Új napon 2*kattintva visszaíródik a mezőbe. Alul pipával kiválasztható, hogy az összes foglalkoztatottat sorolja vagy csak a lejelentetteket. Ha egy ember két helyen van egy napon foglalkoztatva, akkor mind a két helyet be kell vinni egy nappal, a rendszer kiértékelésnél az egymás melletti napokat összevonja egy napra összesített munkabérre, és egy napi közteherre. Hó-végi jelentésnél NAV felé ?08A/M bizonylaton az egymás melletti napokat tól-ig határként mutatja ki.


Elvégzett munkák javítása

Tetején kiválasztható mit szeretne javítani. Javításhoz beviteli dátum szerint gyűjtsön vagy foglalkoztatott. Utána adatbázisból kiveszi a tételeket és itt megjeleníti. Javítható a napon, norma, teljesítmény, csoport, és jellege mező. A norma, és teljesítménx közvetlen írható. A többi mező 2*kattintással javítható. Mindíg az aktuális soron javít. Ha jellege mezőt javítja a közteher mező is módosulhat a törzsadatban beállítottak szerint. Itt lehet sort törölni is az [Kijelölt törölve] gombbal. Kilépés mentéskor a javított tételeket visszaírja az adatbázisba.


NAV-nak hó végi jelentés

Ez a ??08A/M hó végi jelentés kifizetésekről. A jelentéshez szükséges internet hozzáférés, az aktuális évi NAV nyomtatvány, ÁNYK telepítve, és ha be szertné küldeni ügyfélkapu regisztráció.

Ki kell az időszakot jelölni. Utána [Időszakra kigyűjtés]. Ami a jobb oldalon megmutatja a tételeket. Ez után a [Jelentés] gombot kell megnyomni. A kigyűjtött tételeket, kerekitve, 5 Ft-re kerekítve kigyűjti és átláp az ÁNYK-ba ahol javítható, törölhető, feladható a dokumentum. A napokat egy személynél, ha egymás mellett vannak, és nem eltérő jelleg van beállítva összevonja. Így a nyomtatvány ??08M-13 napjainál tól ig mutatja a napokat. Ha egy ember két helyen van egy napon foglalkoztatva, akkor mind a két helyet be kell vinni egy nappal, a rendszer kiértékelésnél az egymás melletti napokat összevonja egy napra összesített munkabérre, és egy napi közteherre. Hó-végi jelentésnél NAV felé ?08A/M bizonylaton az egymás melletti napokat tól-ig határként mutatja ki.


Kifizetési jegyzék

Időszakra kérhető. 5 Ft kerekítést tartalmaz személyre összevonva.


Listák

A itt látható listák érhetők el. Mindet időszakra lehet szűkíteni.


JELENLÉTI NYOMTATÁS

Itt lehet kiválasztani, hogy a felvett (törzsadatban) dolgozók közül kit akar kinyomtatni. Akár egyszerre többet is.

A nyomtatásra? Oszlopnál kettőt kattintva állítható be kiket nyomtasson (igen). Alul a nyomtatásra kerülő adatokat lehet beállítani. A nyomtatás 5 napos (soros) mivel egy huzamban 5 napot lehet foglalkoztatni. Ha alul értékeket állít be mind az 5 napra kiírja a rendszer. Példányszám is alul állítható. Az alsó három sorban tetszőleges megjegyzést írhat ami rá kerül a jelenléti ívre. Minden dolgozó kinyomtatott jelenléti íve egyedi sorszámot kap és a rendszer megjegyzi.

Nyomtatás formája:


MÁSOLAT, TÖRLÉS

Elmentett jelenléti ívről másolatot kérni. Itt lehet jelenléti ívet törölni.

Törölteket a rendszer megőrzi és itt lehet ezeket megtekinteni ha alul a pipát beállítja alul.

A másolat és a törölt jelenléti csak hasonlít az eredetire a bizonylaton több helyen jelezve van, hogy

másolat vagy törölt.


ADATKÉRŐ LAP


ÜRESLAP ÉS SORSZÁM BEÁLLÍTÁS

Felül lehet kipipálni, hogy sorszámmal vagy nélküle nyomtasson.

Alul lehet kipipálni hogy üres lapot nyomtasson.


IGAZOLÁS NYOMTATÁSA

Kiválasztó ahol 'Neve'-nél bejelölhető kinek nyomtassa. Minden fehér rész újra írható és a rendszer megjegyzi.

Nyomtatási kép:


KARBANTARTÁS


KARBANTARTÁS

Olyan munkák elvégzése mely nem közvetlen az üzemeléshez tartozik:

Rendszer alaphelyzetbe, azaz törlései.

Regisztráció ami a bemutatóból teljes értékűvé, azaz teljesen használhatóvá teszi a rendszert.

Leírás ami a rendszer futása alatt F1 is elérhető.

Készült a rendszer elkészítésének összefoglalója.

Internet a honlapom elérése.

Mentés nincs beépítve, ezt a rendszergazdának kell megoldani a C:\alkalvb6 könyvtár teljes mentésével. Adatbázis az alkal.mdb ben található.